Текущее время: 19 май 2022, 21:47 • Часовой пояс: UTC + 3 часа
Сообщения без ответов | Активные темы

Конфликт ТВ-Тюнера и вэб камеры (Решено)

Начать новую темуОтветить на тему Страница 1 из 1 [ Сообщений: 9 ]
Версия для печати Пред. тема | След. тема
АвторСообщение
Сообщение Добавлено: 30 май 2010, 21:04. Заголовок сообщения:  Конфликт ТВ-Тюнера и вэб камеры (Решено)
Зарегистрирован:
    30 май 2010, 20:56
Сообщения: 3
ТВ тюнер Beholder TV609FM,сегодня решил поставить его в комп,установил программу TVtime из репов убунты,а она даже не запускается,на долю секунды появляется черное окно и на этом все.Тюнер в списке устройств есть.После некотрых манипуляций с бубном выяснил причину,виновата вэб-камера,как только я ее отключаю все нормально работает,как только включаю TVtime запускается,на мгновение появляется окно программы и идет только звук от телеканала,изображение отсутствует.
Последний раз редактировалось dmitry287 02 авг 2010, 16:37, всего редактировалось 1 раз.
Профиль 
Сообщение Добавлено: 01 июн 2010, 04:07. Заголовок сообщения: 
Beholder
Аватара пользователя
Зарегистрирован:
    19 авг 2004, 11:51
Сообщения: 396
Определить по dmesg каким устройством является веб-камера, а каким ТВ тюнер. Запускать tvtime с опцией -d /dev/videoN , где N - номер устройства ТВ тюнера.
Профиль 
Сообщение Добавлено: 01 июн 2010, 21:16. Заголовок сообщения: 
Аватара пользователя
Зарегистрирован:
    17 май 2010, 22:05
Сообщения: 15
Цитата из хелпа твтайма:
Код:
-d, --device=DEVICE        video4linux device (defaults to /dev/video0).

У меня веб-камера всегда /dev/video0
Тюнер соответственно будет /dev/video1
т.е. вам надо к строке запуска твтайма в ярлыке, добавить
Код:
-d /dev/video1
Мы не сдаемся. Мы всегда добиваемся своей цели.
Профиль 
Сообщение Добавлено: 02 июн 2010, 00:27. Заголовок сообщения: 
Зарегистрирован:
    30 май 2010, 20:56
Сообщения: 3
не помогает
при подключенной вэбке тв не запускается,идет только звук,даже закрыть программу невозможно так как нет окна твтайма и на панели задач он так же отсутствует.Чтобы закрыть твтайм приходится выдергивать вэбку,повторно запускать твтайм,после этого тв начинает нормально показывать и только потом закрывать твтайм.
Профиль 
Сообщение Добавлено: 10 июн 2010, 18:09. Заголовок сообщения: 
Зарегистрирован:
    06 июн 2010, 15:24
Сообщения: 3
Подтверждаю наличие проблемы.
Пока помогает загрузка с отключенной вебкой.
Профиль 
Сообщение Добавлено: 13 июн 2010, 18:45. Заголовок сообщения:  Один из вариантов
Зарегистрирован:
    19 мар 2010, 00:08
Сообщения: 13
Можно указать модулю твтюнера (saa7134) загружаться с определённым номером, причём номер должен быть за пределами автоматически определяемых системой номеров, например 99 (с большим запасом :D ).
Например это можно сделать, создав файл tuner.conf в папке /etc/modprobe.d/ следующего содержания:

options saa7134 secam=d video_nr=99

тогда твтюнер будет загружаться под /dev/video99
В tvtime тоже нужно указать этот номер, для этого открыть в редакторе файл ~/.tvtime/tvtime.xml и в нём поменять в строке, содержащей:

/dev/video0 на /dev/video99

и сохранить.
Теперь сколько бы Вы не подключали вебкамер и прочих видео устройст (но не больше 98 одновременно :wink: ), твтюнер всегда будет под номером 99!
LinuxMint 11 Katya, ядро 2.6.38-8, Behold H6
Профиль 
Сообщение Добавлено: 15 июн 2010, 08:10. Заголовок сообщения: 
Beholder
Аватара пользователя
Зарегистрирован:
    19 авг 2004, 11:51
Сообщения: 396
Попробовать mplayer как он будет работать, tvtime заброшен, счастье что он вообще еще работает.
Профиль 
Сообщение Добавлено: 02 авг 2010, 16:34. Заголовок сообщения: 
Зарегистрирован:
    30 май 2010, 20:56
Сообщения: 3
Нашел такое решение:
Проблема существует для большинства устройств использующих Usb audio . (веб камеры, гарнитуры и тд.. )
Помогло установить более старые пакеты.
Вот старые рабочие версии:
https://launchpad.net/ubuntu/+source/tv ... 1_i386.deb
https://launchpad.net/ubuntu/+source/tv ... _amd64.deb

проверил РАБОТАЕТ
Профиль 
Сообщение Добавлено: 27 янв 2011, 07:22. Заголовок сообщения:  Еще одно решение
Зарегистрирован:
    19 мар 2010, 00:08
Сообщения: 13
Если кроме вебкамеры (имеется ввиду микрофон расположенный на вебкамере) других USB звуковых устройств нет и не планируется, то можно сделать следующее:

в конец файла /etc/modprobe.d/blacklist.conf добавить следующую строчку

blacklist snd_usb_audio

это отключит инициализацию звуковых устройств с интерфейсом USB и конфликт при запуске TVTIME исчезнет, при этом видео интерфейс вебкамеры будет работать как прежде.
LinuxMint 11 Katya, ядро 2.6.38-8, Behold H6
Профиль 
Показать сообщения за:  Поле сортировки:    
Начать новую темуОтветить на тему  Страница 1 из 1  [ Сообщений: 9 ]  
Кто сейчас на конференции
Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 0
Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения
Найти:  
Перейти: